Connecting to database ..

Have you seen this message “Connecting to database ..” in GenDetective and been frustrated that it never goes away?  If so, the solution to this issue is simple and quick.

First, what is the cause of the issue?  With multiple versions of Access on your machine, a different version of Access is trying to open the GenDetective database.  This can be very frustrating!  In the blog post #1 Question Asked About GenDetective I discuss the software that is installed by GenDetective during installation.

What’s the solution?  You can easily address this with a couple clicks of your mouse:

  1. Install GenDetective v2.2 (if you haven’t already done so)
  2. Reboot to make sure no part of GenDetective is running
  3. Open your My Documents\GenDetective folder
  4. Find genD_v2.gen (~492 mb or larger) and double-click it
  5. An Office pop-up will appear saying it is reconfiguring please wait.  This message may stay on the screen and flicker for a few minutes.
  6. When the password pop-up appears, the reconfiguration is finished, press the cancel button
  7. Run GenDetective 2 !

Once fixed, can this issue happen again?  Yes, it may, if you are switching between versions of Office.  However, if it does happen, repeat the above steps and the issue will be resolved.

The obvious question is “Can’t you make this whole thing go away”?  We are working on a solution and took a giant step forward with in GenDetective 2.2.  However, when combining different operating systems (XP, Vista, Windows 7 & Windows 8) with the versions of Office (XP, 2003, 2007, 2010 & 2013), it has been challenging to find a solution that hides this issue for all.

Happy genealogy researching ..

This entry was posted in Genealogy software and tagged , , , , , , , , . Bookmark the permalink.

2 Responses to Connecting to database ..

  1. Becky Pyle says:

    delighted to get this message!!! I just got a new computer and was banging my head against the wall trying to reinstall GenDetective (even though it was the same old Windows 7 I had before). I will try this fix very soon as soon as I resolve some other issues. Thanks!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s